[Solved] Ubuntu Update Broke My WiFi

Preface

I have Ubuntu 14.04 with linux kernel 4.4.0-113-generic on a Dell Vostro 1000. This laptop’s maxed out processor and RAM are just enough for Trusty Tahr, so upgrading to 16.04 isn’t an option.

The Problem

I update whenever it asks. After the latest update, WiFi wouldn’t work. This happens fairly often. She’s a good dog, but she’s old. Restarting usually gives me bars. This time, however, I noticed there was no option for Wireless in the bottom panel’s network menu. Nor was it in Network Settings. Googling brought some old results but the situations and apparent cause were similar — an update broke the card/driver.

This post assumes your router works, your machine has any network connectivity at all, and there is, in fact, a signal to receive. If apes and/or zombies recently conquered your region, your laptop might be functioning as expected.

Quick Solution To Try But Didn’t Work for Me

Press Fn + F2.
I’d never noticed the little wireless symbol on that key before. Apparently, it toggles your WiFi. This didn’t work because, as we’ll see below, the laptop didn’t know it has a wireless card to turn on and off.

Hard Key on Outside of Laptop
Ye Olde Delle Vostro doesn’t have any such switch or slider and neither did some posting this problem (many people suggested trying it).

Kill Process That Is Blocking WiFi
This target process may or may not exist.

sudo /usr/sbin/rfkill unblock wifi

Solutions That Worked for Others I Didn’t Need to Try

This solution is especially handy if you have no network connection on that machine at all.

Solution That Worked for Me

Courtesy of overclock.net forums c. 2014

Run ifconfig to see your networking shizzle.

While broken, mine showed only eth0 and lo.

  • Eth0 = ethernet card
  • wlan0 = wireless card
  • lo = “loopback device … used for stuff to communicate on your system”
  • docker0 = I don’t know what that is

The overclock forum post included instructions for those with no network connectivity as well but I didn’t need them and am not including them here.

Type the following to see what driver is loaded and see what card you have.

lspci -v | grep -i network -A 6

My results showed my broadcom driver and, if memory serves, that something was denied (like the post at overclock). I have a card but it wasn’t recognized so the solution was to remove whatever the update added and/or reinstall whatever the update removed.

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source && sudo apt-get install b43-fwcutter firmware-b43-installer

That first part took a long time. Along the way, it asked me to confirm and when it was finished, I had to confirm it could do the second task.

Restart.

Everything is, obviously, working fine now.

Advertisements

About jotascript

Aiming to please. Seeking to impress.
This entry was posted in Command Line, Linux, UNIX and tagged . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s